$re = '/^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$/m';
$str = ' John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.';
$subst = "Ye Tar Oo Yetaroo3 Uyetar Goffery ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;