const regex = new RegExp('^([A-Z]|[a-z]|\\s)+(,\\s*(Jr\\.|Sr\\.|[IV]*))?$', 'gm')
const str = ` John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.`;
const subst = `Ye Tar Oo Yetaroo3 Uyetar Goffery `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);