// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)").unwrap();
let string = "discord.com/invite/abc123
discordapp.com/invite/123abc
discord.gg/invite/abc123
discord.gg/123abc
discord.com/friend-invite/abc123
discord.com/servers/123abc
discordapp.com/servers/abc123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}