using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)";
string input = @"discord.com/invite/abc123
discordapp.com/invite/123abc
discord.gg/invite/abc123
discord.gg/123abc
discord.com/friend-invite/abc123
discord.com/servers/123abc
discordapp.com/servers/abc123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}