package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)`)
var str = `discord.com/invite/abc123
discordapp.com/invite/123abc
discord.gg/invite/abc123
discord.gg/123abc
discord.com/friend-invite/abc123
discord.com/servers/123abc
discordapp.com/servers/abc123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}