$re = '/discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)/m';
$str = 'discord.com/invite/abc123
discordapp.com/invite/123abc
discord.gg/invite/abc123
discord.gg/123abc
discord.com/friend-invite/abc123
discord.com/servers/123abc
discordapp.com/servers/abc123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);