#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)discord(?:app)?\.com\/(?:(friend-)?invite|servers)?\/([a-z0-9\-]+)|discord\.gg\/(?:\S+\/)?([a-z0-9\-]+)"
Local $sString = "discord.com/invite/abc123" & @CRLF & _
"discordapp.com/invite/123abc" & @CRLF & _
"discord.gg/invite/abc123" & @CRLF & _
"discord.gg/123abc" & @CRLF & _
"discord.com/friend-invite/abc123" & @CRLF & _
"discord.com/servers/123abc" & @CRLF & _
"discordapp.com/servers/abc123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")