// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(([\-]?[0-9]*[a-z])([\-\+][0-9]*)\)\^([0-9]+)").unwrap();
let string = "(x+1)^2
(p-1)^3
(2f+4)^6
(12t+43)^2
(12t+43)^23
(-12t+43)^2
(x+1)^0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}