#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(([\-]?[0-9]*[a-z])([\-\+][0-9]*)\)\^([0-9]+)"
Local $sString = "(x+1)^2" & @CRLF & _
"(p-1)^3" & @CRLF & _
"(2f+4)^6" & @CRLF & _
"(12t+43)^2" & @CRLF & _
"(12t+43)^23" & @CRLF & _
"(-12t+43)^2" & @CRLF & _
"(x+1)^0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")