const regex = /\(([\-]?[0-9]*[a-z])([\-\+][0-9]*)\)\^([0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(([\\-]?[0-9]*[a-z])([\\-\\+][0-9]*)\\)\\^([0-9]+)', 'gm')
const str = `(x+1)^2
(p-1)^3
(2f+4)^6
(12t+43)^2
(12t+43)^23
(-12t+43)^2
(x+1)^0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}