re = /\(([\-]?[0-9]*[a-z])([\-\+][0-9]*)\)\^([0-9]+)/m
str = '(x+1)^2
(p-1)^3
(2f+4)^6
(12t+43)^2
(12t+43)^23
(-12t+43)^2
(x+1)^0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end