import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([\\-]?[0-9]*[a-z])([\\-\\+][0-9]*)\\)\\^([0-9]+)";
final String string = "(x+1)^2\n"
+ "(p-1)^3\n"
+ "(2f+4)^6\n"
+ "(12t+43)^2\n"
+ "(12t+43)^23\n"
+ "(-12t+43)^2\n"
+ "(x+1)^0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}