import Foundation
let pattern = #"\$(\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\}|(?P<cmd_var>[a-zA-Z0-9_]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"pcasl_cbf_adapter --grase-kgn --verbose --subject-id=$SUBJECT_ID --session-id=${SESSION_ID} "$IN_DIR" "${OUT_URI}""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)