const regex = new RegExp('\\$(\\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\\}|(?P<cmd_var>[a-zA-Z0-9_]+))', 'gm')
const str = `pcasl_cbf_adapter --grase-kgn --verbose --subject-id=\$SUBJECT_ID --session-id=\${SESSION_ID} "\$IN_DIR" "\${OUT_URI}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}