#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$(\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\}|(?P<cmd_var>[a-zA-Z0-9_]+))"
Local $sString = "pcasl_cbf_adapter --grase-kgn --verbose --subject-id=$SUBJECT_ID --session-id=${SESSION_ID} "$IN_DIR" "${OUT_URI}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")