re = /\$(\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\}|(?P<cmd_var>[a-zA-Z0-9_]+))/m
str = 'pcasl_cbf_adapter --grase-kgn --verbose --subject-id=$SUBJECT_ID --session-id=${SESSION_ID} "$IN_DIR" "${OUT_URI}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end