$re = '/\$(\{(?P<braced_cmd_var>[a-zA-Z0-9_]+)\}|(?P<cmd_var>[a-zA-Z0-9_]+))/m';
$str = 'pcasl_cbf_adapter --grase-kgn --verbose --subject-id=$SUBJECT_ID --session-id=${SESSION_ID} "$IN_DIR" "${OUT_URI}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);