import Foundation
let pattern = #"^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
sc_1-file
sc_2-file
sc_3-file
sc_4-file
sc_5-file
sc_6-file
sc_7-file
sc_8-file
sc_9-file
sc_10-file
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)