#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$"
Local $sString = "sc_1-file" & @CRLF & _
"sc_2-file" & @CRLF & _
"sc_3-file" & @CRLF & _
"sc_4-file" & @CRLF & _
"sc_5-file" & @CRLF & _
"sc_6-file" & @CRLF & _
"sc_7-file" & @CRLF & _
"sc_8-file" & @CRLF & _
"sc_9-file" & @CRLF & _
"sc_10-file"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")