import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<prefix>-{0,2}[A-Za-z\\s_\\-:]+)?(?<version>\\d+)(?<sufix>.+)$";
final String string = "sc_1-file\n"
+ "sc_2-file\n"
+ "sc_3-file\n"
+ "sc_4-file\n"
+ "sc_5-file\n"
+ "sc_6-file\n"
+ "sc_7-file\n"
+ "sc_8-file\n"
+ "sc_9-file\n"
+ "sc_10-file";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}