// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$").unwrap();
let string = "sc_1-file
sc_2-file
sc_3-file
sc_4-file
sc_5-file
sc_6-file
sc_7-file
sc_8-file
sc_9-file
sc_10-file";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}