package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<prefix>-{0,2}[A-Za-z\s_\-:]+)?(?<version>\d+)(?<sufix>.+)$`)
var str = `sc_1-file
sc_2-file
sc_3-file
sc_4-file
sc_5-file
sc_6-file
sc_7-file
sc_8-file
sc_9-file
sc_10-file`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}