use strict;
my $str = 'Programciyiz.NET Düzenli ifadelere hoşgeldiniz!
Yukarıdaki kutucuğa düzenli ifade yapısını girerek; ifadeleri & eşleşmeleri görebilir ve seçeneklerini ayarlayabilir ve düzenleyebilirsiniz. Geri almak için Ctrl+Z kullanın. Yapıyı kaydedip linki paylaşabilirsiniz.
Örnek deneme metni:
abcçdefgğhıijklmnoöpqrsştuüvwxyz ABCÇDEFGĞHIİJKLMNOÖPQRSŞTUÜVWXYZ
0123456789 +-.,!@#$%^&*();\\/|<>"\'
12345 -98.7 3.141 .6180 9,000 +42
+90(224)294 26 62
posta@sukrukaya.net
http://sukrukaya.net';
my $regex = qr/[a-zA-ZĞÜŞİÖÇığüşöç]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}