const regex = /[a-zA-ZĞÜŞİÖÇığüşöç]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-ZĞÜŞİÖÇığüşöç]', 'g')
const str = `Programciyiz.NET Düzenli ifadelere hoşgeldiniz!
Yukarıdaki kutucuğa düzenli ifade yapısını girerek; ifadeleri & eşleşmeleri görebilir ve seçeneklerini ayarlayabilir ve düzenleyebilirsiniz. Geri almak için Ctrl+Z kullanın. Yapıyı kaydedip linki paylaşabilirsiniz.
Örnek deneme metni:
abcçdefgğhıijklmnoöpqrsştuüvwxyz ABCÇDEFGĞHIİJKLMNOÖPQRSŞTUÜVWXYZ
0123456789 +-.,!@#\$%^&*();\\/|<>"'
12345 -98.7 3.141 .6180 9,000 +42
+90(224)294 26 62
posta@sukrukaya.net
http://sukrukaya.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}