import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-ZĞÜŞİÖÇığüşöç]";
final String string = "Programciyiz.NET Düzenli ifadelere hoşgeldiniz!\n\n"
+ "Yukarıdaki kutucuğa düzenli ifade yapısını girerek; ifadeleri & eşleşmeleri görebilir ve seçeneklerini ayarlayabilir ve düzenleyebilirsiniz. Geri almak için Ctrl+Z kullanın. Yapıyı kaydedip linki paylaşabilirsiniz. \n\n"
+ "Örnek deneme metni:\n"
+ "abcçdefgğhıijklmnoöpqrsştuüvwxyz ABCÇDEFGĞHIİJKLMNOÖPQRSŞTUÜVWXYZ\n"
+ "0123456789 +-.,!@#$%^&*();\\/|<>\"'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "+90(224)294 26 62\n"
+ "posta@sukrukaya.net\n"
+ "http://sukrukaya.net";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}