package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-ZĞÜŞİÖÇığüşöç]`)
var str = `Programciyiz.NET Düzenli ifadelere hoşgeldiniz!
Yukarıdaki kutucuğa düzenli ifade yapısını girerek; ifadeleri & eşleşmeleri görebilir ve seçeneklerini ayarlayabilir ve düzenleyebilirsiniz. Geri almak için Ctrl+Z kullanın. Yapıyı kaydedip linki paylaşabilirsiniz.
Örnek deneme metni:
abcçdefgğhıijklmnoöpqrsştuüvwxyz ABCÇDEFGĞHIİJKLMNOÖPQRSŞTUÜVWXYZ
0123456789 +-.,!@#$%^&*();\/|<>"'
12345 -98.7 3.141 .6180 9,000 +42
+90(224)294 26 62
posta@sukrukaya.net
http://sukrukaya.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}