#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-ZĞÜŞİÖÇığüşöç]"
Local $sString = "Programciyiz.NET Düzenli ifadelere hoşgeldiniz!" & @CRLF & _
"" & @CRLF & _
"Yukarıdaki kutucuğa düzenli ifade yapısını girerek; ifadeleri & eşleşmeleri görebilir ve seçeneklerini ayarlayabilir ve düzenleyebilirsiniz. Geri almak için Ctrl+Z kullanın. Yapıyı kaydedip linki paylaşabilirsiniz. " & @CRLF & _
"" & @CRLF & _
"Örnek deneme metni:" & @CRLF & _
"abcçdefgğhıijklmnoöpqrsştuüvwxyz ABCÇDEFGĞHIİJKLMNOÖPQRSŞTUÜVWXYZ" & @CRLF & _
"0123456789 +-.,!@#$%^&*();\/|<>"'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"+90(224)294 26 62" & @CRLF & _
"posta@sukrukaya.net" & @CRLF & _
"http://sukrukaya.net"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")