import Foundation
let pattern = #"<Compile Include=".*Document\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<Compile Include="..\..\Document\Source\CommonAssemblyInfo.cs">
<Link>CommonAssemblyInfo.cs</Link>
</Compile>
<Compile Include="..\..\Reports\ReportsCore\Rendering\Components\InteractiveEventIDs.cs">
<Link>Rendering\InteractiveEventIDs.cs</Link>
</Compile>
<Compile Include="..\..\SL\CommonFiles\SafeGraphics.cs">
<Link>SafeGraphics.cs</Link>
</Compile>
<Compile Include="..\..\VersionInfo.cs">
<Link>VersionInfo.cs</Link>
</Compile>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)