$re = '/<Compile Include=".*Document\\\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)/';
$str = ' <Compile Include="..\\..\\Document\\Source\\CommonAssemblyInfo.cs">
<Link>CommonAssemblyInfo.cs</Link>
</Compile>
<Compile Include="..\\..\\Reports\\ReportsCore\\Rendering\\Components\\InteractiveEventIDs.cs">
<Link>Rendering\\InteractiveEventIDs.cs</Link>
</Compile>
<Compile Include="..\\..\\SL\\CommonFiles\\SafeGraphics.cs">
<Link>SafeGraphics.cs</Link>
</Compile>
<Compile Include="..\\..\\VersionInfo.cs">
<Link>VersionInfo.cs</Link>
</Compile>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);