using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Compile Include="".*Document\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)";
string input = @" <Compile Include=""..\..\Document\Source\CommonAssemblyInfo.cs"">
<Link>CommonAssemblyInfo.cs</Link>
</Compile>
<Compile Include=""..\..\Reports\ReportsCore\Rendering\Components\InteractiveEventIDs.cs"">
<Link>Rendering\InteractiveEventIDs.cs</Link>
</Compile>
<Compile Include=""..\..\SL\CommonFiles\SafeGraphics.cs"">
<Link>SafeGraphics.cs</Link>
</Compile>
<Compile Include=""..\..\VersionInfo.cs"">
<Link>VersionInfo.cs</Link>
</Compile>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}