# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Compile Include=\".*Document\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)"
test_str = (" <Compile Include=\"..\\..\\Document\\Source\\CommonAssemblyInfo.cs\">\n"
" <Link>CommonAssemblyInfo.cs</Link>\n"
" </Compile>\n"
" <Compile Include=\"..\\..\\Reports\\ReportsCore\\Rendering\\Components\\InteractiveEventIDs.cs\">\n"
" <Link>Rendering\\InteractiveEventIDs.cs</Link>\n"
" </Compile>\n"
" <Compile Include=\"..\\..\\SL\\CommonFiles\\SafeGraphics.cs\">\n"
" <Link>SafeGraphics.cs</Link>\n"
" </Compile>\n"
" <Compile Include=\"..\\..\\VersionInfo.cs\">\n"
" <Link>VersionInfo.cs</Link>\n"
" </Compile>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.