re = /^(([a-z]+)_([0-9]+)(_([0-9]+))*)\-([0-9]+)x([0-9]+)\-([0-9]{1})([0-9abcdef]{6}){0,1}\.(jpg|gif|png)/
str = 'attractions_300-217x168-1.jpg
villa_27_11213-850x567-1.jpg
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end