use strict;
my $str = 'attractions_300-217x168-1.jpg
villa_27_11213-850x567-1.jpg
';
my $regex = qr/^(([a-z]+)_([0-9]+)(_([0-9]+))*)\-([0-9]+)x([0-9]+)\-([0-9]{1})([0-9abcdef]{6}){0,1}\.(jpg|gif|png)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}