const regex = /^(([a-z]+)_([0-9]+)(_([0-9]+))*)\-([0-9]+)x([0-9]+)\-([0-9]{1})([0-9abcdef]{6}){0,1}\.(jpg|gif|png)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([a-z]+)_([0-9]+)(_([0-9]+))*)\\-([0-9]+)x([0-9]+)\\-([0-9]{1})([0-9abcdef]{6}){0,1}\\.(jpg|gif|png)', '')
const str = `attractions_300-217x168-1.jpg
villa_27_11213-850x567-1.jpg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}