#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(([a-z]+)_([0-9]+)(_([0-9]+))*)\-([0-9]+)x([0-9]+)\-([0-9]{1})([0-9abcdef]{6}){0,1}\.(jpg|gif|png)"
Local $sString = "attractions_300-217x168-1.jpg" & @CRLF & _
"villa_27_11213-850x567-1.jpg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")