$re = '/^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+/m';
$str = 'http://wwwgooglees.com
pepe.es
ALOnso.es.ese.eso.shda;lsd.sadfaw
g.co
123Ahsplas.edu.gAva.essssss
sergicampos112.com
https://rexex101.com
como maximo 127 dominios
nombre de dominio 253 char
cada level name maximo 63 char
level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos
top level no puede ser todo numeros';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);