#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+"
Local $sString = "http://wwwgooglees.com" & @CRLF & _
"pepe.es" & @CRLF & _
"ALOnso.es.ese.eso.shda;lsd.sadfaw" & @CRLF & _
"g.co" & @CRLF & _
"123Ahsplas.edu.gAva.essssss" & @CRLF & _
"sergicampos112.com" & @CRLF & _
"https://rexex101.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"como maximo 127 dominios " & @CRLF & _
"nombre de dominio 253 char" & @CRLF & _
"cada level name maximo 63 char" & @CRLF & _
"level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos" & @CRLF & _
"top level no puede ser todo numeros"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")