import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-z:\\/0-9]+\\.[a-zA-z0-9\\-].+";
final String string = "http://wwwgooglees.com\n"
+ "pepe.es\n"
+ "ALOnso.es.ese.eso.shda;lsd.sadfaw\n"
+ "g.co\n"
+ "123Ahsplas.edu.gAva.essssss\n"
+ "sergicampos112.com\n"
+ "https://rexex101.com\n\n\n\n"
+ "como maximo 127 dominios \n"
+ "nombre de dominio 253 char\n"
+ "cada level name maximo 63 char\n"
+ "level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos\n"
+ "top level no puede ser todo numeros";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}