use strict;
my $str = 'http://wwwgooglees.com
pepe.es
ALOnso.es.ese.eso.shda;lsd.sadfaw
g.co
123Ahsplas.edu.gAva.essssss
sergicampos112.com
https://rexex101.com
como maximo 127 dominios
nombre de dominio 253 char
cada level name maximo 63 char
level names lowercase uppercase, ascii,digitos y signo menos pero no puede empezar ni acabar en simbolo menos
top level no puede ser todo numeros';
my $regex = qr/^[a-zA-z:\/0-9]+\.[a-zA-z0-9\-].+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}