import Foundation
let pattern = #"function (.*).*\((.*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
PLAYER_BUFF_MINUTES = 10
FORCE_BUFF_MINUTES = 30
-- ------------------------------------------------------------------------------------
CHARGE_ENERGY = 100000
local charging_station_multiplier = 1
function ResetPlayer(playername)
if (game.players[playername] ~= nil) then
RemoveOrResetPlayer(game.players[playername], false, true, true, true)
SeparateSpawnsPlayerCreated(game.players[playername].index, true)
end
end
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)