using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function (.*).*\((.*)\)";
string input = @"PLAYER_BUFF_MINUTES = 10
FORCE_BUFF_MINUTES = 30
-- ------------------------------------------------------------------------------------
CHARGE_ENERGY = 100000
local charging_station_multiplier = 1
function ResetPlayer(playername)
if (game.players[playername] ~= nil) then
RemoveOrResetPlayer(game.players[playername], false, true, true, true)
SeparateSpawnsPlayerCreated(game.players[playername].index, true)
end
end";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}