#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "function (.*).*\((.*)\)"
Local $sString = "PLAYER_BUFF_MINUTES = 10" & @CRLF & _
"FORCE_BUFF_MINUTES = 30" & @CRLF & _
"" & @CRLF & _
"-- ------------------------------------------------------------------------------------" & @CRLF & _
"" & @CRLF & _
"CHARGE_ENERGY = 100000" & @CRLF & _
"" & @CRLF & _
"local charging_station_multiplier = 1" & @CRLF & _
"" & @CRLF & _
"function ResetPlayer(playername)" & @CRLF & _
" if (game.players[playername] ~= nil) then" & @CRLF & _
" RemoveOrResetPlayer(game.players[playername], false, true, true, true)" & @CRLF & _
" SeparateSpawnsPlayerCreated(game.players[playername].index, true)" & @CRLF & _
" end" & @CRLF & _
"end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")