import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "function (.*).*\\((.*)\\)";
final String string = "PLAYER_BUFF_MINUTES = 10\n"
+ "FORCE_BUFF_MINUTES = 30\n\n"
+ "-- ------------------------------------------------------------------------------------\n\n"
+ "CHARGE_ENERGY = 100000\n\n"
+ "local charging_station_multiplier = 1\n\n"
+ "function ResetPlayer(playername)\n"
+ " if (game.players[playername] ~= nil) then\n"
+ " RemoveOrResetPlayer(game.players[playername], false, true, true, true)\n"
+ " SeparateSpawnsPlayerCreated(game.players[playername].index, true)\n"
+ " end\n"
+ "end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}