import Foundation
let pattern = #"(?<=^|\n)(?P<spacer>[[:blank:]]*(?:\{[^{]*(?&spacer)[^}]*\}[[:blank:]]*)[[:blank:]]*|[[:blank:]]+)(\d+)\.(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8]))(?:(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8])))?(?&spacer)?(?=$|\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1. a1 e1
2. a2 e2
3. a3 b4
4. a4 a5
5. Cb5 b4<
{~6. b4 Cb3~}
6. b4 Se3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)