use strict;
my $str = ' 1. a1 e1
2. a2 e2
3. a3 b4
4. a4 a5
5. Cb5 b4<
{~6. b4 Cb3~}
6. b4 Se3';
my $regex = qr/(?<=^|\n)(?P<spacer>[[:blank:]]*(?:\{[^{]*(?&spacer)[^}]*\}[[:blank:]]*)[[:blank:]]*|[[:blank:]]+)(\d+)\.(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8]))(?:(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8])))?(?&spacer)?(?=$|\n)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}