$re = '/(?<=^|\n)(?P<spacer>[[:blank:]]*(?:\{[^{]*(?&spacer)[^}]*\}[[:blank:]]*)[[:blank:]]*|[[:blank:]]+)(\d+)\.(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8]))(?:(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8])))?(?&spacer)?(?=$|\n)/';
$str = ' 1. a1 e1
2. a2 e2
3. a3 b4
4. a4 a5
5. Cb5 b4<
{~6. b4 Cb3~}
6. b4 Se3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);