import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\n)(?P<spacer>[[:blank:]]*(?:\\{[^\\{]*(?&spacer)[^\\}]*\\}[[:blank:]]*)[[:blank:]]*|[[:blank:]]+)(\\d+)\\.(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8]))(?:(?&spacer)(?:([1-8])?([a-h])([1-8])([+-<>])([1-8]*)|([FSC])?([a-h])([1-8])))?(?&spacer)?(?=$|\\n)";
final String string = " 1. a1 e1\n"
+ " 2. a2 e2\n"
+ " 3. a3 b4\n"
+ " 4. a4 a5\n"
+ " 5. Cb5 b4<\n"
+ "{~6. b4 Cb3~}\n"
+ " 6. b4 Se3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}