# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(https:\/\/cloud\.saikoanimes\.net\/.*)\" c.*"
test_str = ("\n"
" <a href=\"https://cloud.saikoanimes.net/11Yu\" class=\"btn-sa\" target=\"blank\">01</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXz\" class=\"btn-sa\" target=\"blank\">02</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXv\" class=\"btn-sa\" target=\"blank\">03</a>\n"
"<a href=\"https://cloud.saikoanimes.net/11Yx\" class=\"btn-sa\" target=\"blank\">04</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXt\" class=\"btn-sa\" target=\"blank\">05</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXw\" class=\"btn-sa\" target=\"blank\">06</a>\n"
"<a href=\"https://cloud.saikoanimes.net/11Yv\" class=\"btn-sa\" target=\"blank\">07</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXx\" class=\"btn-sa\" target=\"blank\">08</a>\n"
"<a href=\"https://cloud.saikoanimes.net/BXy\" class=\"btn-sa\" target=\"blank\">09</a>\n"
"<a href=\"https://cloud.saikoanimes.net/11Yo\" class=\"btn-sa\" target=\"blank\">10</a>\n"
"<a href=\"https://cloud.saikoanimes.net/11Ym\" class=\"btn-sa\" target=\"blank\">11</a>\n"
"<a href=\"https://cloud.saikoanimes.net/11Yw\" class=\"btn-sa final\" target=\"blank\">12</a> ")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.