# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(https:\\/\\/cloud\.saikoanimes\.net\\/.*)" c.*/$1/gm;t' <<< "
<a href=\"https://cloud.saikoanimes.net/11Yu\" class=\"btn-sa\" target=\"blank\">01</a>
<a href=\"https://cloud.saikoanimes.net/BXz\" class=\"btn-sa\" target=\"blank\">02</a>
<a href=\"https://cloud.saikoanimes.net/BXv\" class=\"btn-sa\" target=\"blank\">03</a>
<a href=\"https://cloud.saikoanimes.net/11Yx\" class=\"btn-sa\" target=\"blank\">04</a>
<a href=\"https://cloud.saikoanimes.net/BXt\" class=\"btn-sa\" target=\"blank\">05</a>
<a href=\"https://cloud.saikoanimes.net/BXw\" class=\"btn-sa\" target=\"blank\">06</a>
<a href=\"https://cloud.saikoanimes.net/11Yv\" class=\"btn-sa\" target=\"blank\">07</a>
<a href=\"https://cloud.saikoanimes.net/BXx\" class=\"btn-sa\" target=\"blank\">08</a>
<a href=\"https://cloud.saikoanimes.net/BXy\" class=\"btn-sa\" target=\"blank\">09</a>
<a href=\"https://cloud.saikoanimes.net/11Yo\" class=\"btn-sa\" target=\"blank\">10</a>
<a href=\"https://cloud.saikoanimes.net/11Ym\" class=\"btn-sa\" target=\"blank\">11</a>
<a href=\"https://cloud.saikoanimes.net/11Yw\" class=\"btn-sa final\" target=\"blank\">12</a> "