import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(https:\\/\\/cloud\\.saikoanimes\\.net\\/.*)\" c.*";
final String string = "\n"
+ " <a href=\"https://cloud.saikoanimes.net/11Yu\" class=\"btn-sa\" target=\"blank\">01</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXz\" class=\"btn-sa\" target=\"blank\">02</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXv\" class=\"btn-sa\" target=\"blank\">03</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/11Yx\" class=\"btn-sa\" target=\"blank\">04</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXt\" class=\"btn-sa\" target=\"blank\">05</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXw\" class=\"btn-sa\" target=\"blank\">06</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/11Yv\" class=\"btn-sa\" target=\"blank\">07</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXx\" class=\"btn-sa\" target=\"blank\">08</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/BXy\" class=\"btn-sa\" target=\"blank\">09</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/11Yo\" class=\"btn-sa\" target=\"blank\">10</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/11Ym\" class=\"btn-sa\" target=\"blank\">11</a>\n"
+ "<a href=\"https://cloud.saikoanimes.net/11Yw\" class=\"btn-sa final\" target=\"blank\">12</a> ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}